Monday, December 24, 2007

CISCO 827 Router Config

The first device I am going to configure on my new test lab is the Cisco 827 which will be used to connect to ADSL internet provider.

The Cisco 827 has a ADSL (modem) interface along with a single Ethernet interface.

The flash image on this router is a bit old but we will upgrade it later. For now lets get the damn thing up and running.

Below is the config I have entered into the device. Comments will be in italic.

MarkyZ_Home_827#sh run
Building configuration...

Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MarkyZ_Home_827
!
!
!
!
!
!
ip subnet-zero
!
vpdn enable
no vpdn logging
! VPDN referrs to Virtual Private Dial-Up Network.
!
vpdn-group pppoe
request-dialin
protocol pppoe
! Declaring that the type of VPDN is going to be PPPoE
! "Request-Dialin" is stating that the router is to dial in to a Carrier Device.
! The protocol that is going to be used is PPPoE (Peer to Peer over Ethernet)
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
ip nat inside
shutdown
! The above is just LAN segment junk.
!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
! ATM0 referrs to the ADSL interface of the router.
! Defaults are being used.
!
interface ATM0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 1
!
! 0/35 referrs to the VPI/VCI value set by the isp.
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname username@carrrier.com
ppp chap password p@$$w0rd
!
! Setting up the Dialer Interface. If the carrier uses PAP rather then CHAP, the CHAP commands must be removed and the appropriate PAP commands must be added.
!
! Ethernet MTU is 1500 by default. By setting the default here to 1492 we allow the PPPoE headers to not overrun the default size.
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
! NAT stuff, yay.
! The default route is pointing to the name of the Dialer1 interface rather then the ip since the ip COULD be dynamic. In our case it won't since i own a /30 from the ISP. :)
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.3.0 0.0.0.255
access-list 1 permit 192.168.4.0 0.0.0.255
!
line con 0
transport input none
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

No comments: